Accueil

Aide Movie Collection

Movie Collection

Version 3.0.0.0 (19/07/2004)

Qu'est-ce que Movie Collection ?

Movie Collection est un gestionnaire de films sur tout type de support.

Il est capable de gérer vos DIVX / DVD / VHS...

Vous avez la possibilité de faire des exports de vos films vers excel.

Si vous ne désirez pas saisir tous vos films à la main, il existe une fonctionnalité pour rapatrier toutes les informations ainsi qu'une vignette du film en ligne.
Vous pouvez aussi récupérer tous vos films depuis le logiciel Ant Movie Catalog ou eXtremeMovieManager.
D'autres imports depuis d'autres logiciels sont en prévision.

Ce logiciel intègre
- Une gestion de prêts de films.
- Un juke-box multimédia pour conserver un lien vers vos films ou jaquettes.
- Une gestion multi-collection.
- Des filtres graphiques pour modifier l'aspect de vos images (contraste, luminosité...).
- Un serveur web pour consulter vos films en ligne (accès à votre machine sécurisé)

Movie Collection est en constante évolution et de nombreuses nouveautés sont au rendez-vous....


Options

Options

Configuration de Movie Collection.

  • Paramètres généraux
  • Base de données
  • Application
    • Listes de valeurs
    • Collections
    • Connection

Remarque

Pour que les paramètres soient pris en compte, il vous faudra cliquer sur le bouton enregistrer en bas de l'écran.


Options "Paramètres généraux"

Options "Paramètres généraux"

Les paramètres généraux servent à faire les réglages de l'application afin de personnaliser Movie Collection.

Vérifier si votre logiciel est à jour au démarrage de l'application

Cette option permet de vérifier chaque fois que vous lancerez l'application si une version plus récente de Movie Collection est disponible.

Utiliser une couleur d'ambiance

Cette option permet de coloriser Movie Collection avec une autre couleur que la couleur par défaut de Windows.

Couleur films disponible

Cette option permet de changer la couleur des films disponibles dans la liste des films.

Couleur films prêtés

Cette option permet de changer la couleur des films prêtés dans la liste des films.


Options "Base de données"

Options "Base de données"

Maintenance de la base de données de Movie Collection.

Sauvegarde de la base de données

Cette option permet de sauvegarder votre base de données.

Il est recommandé d'archiver le fichier (*.gbk) sur un support amovible (CR-ROM...) dans le cas d'un crash de votre machine ou une réinstallation.

Le nom donné par défaut au fichier généré contient des informations précieuses ex: "20040719 163259.gbk", il est composé à partir de l'année / mois / jour / heure / min / sec de l'heure de création de la sauvegarde.

Restauration de la base de données

Cette option permet de restaurer une base de donnée précédemment créée à partir d'un fichier (*.gbk).

Optimiser la base de données

Cette option permet de faire un export suivi d'un import de votre base de données.

L'intérêt de cette manipulation est de diminuer la taille de la base de données dans le cas ou vous auriez fait des effacements.

En effet, de nombreuses bases de données n'effacent pas réellement les enregistrements (exemple Microsoft Access) mais les marquent seulement comme effacés. Tout comme pour le cas de Microsoft Access, il vous faudra faire un compactage de la base de données pour supprimer physiquement tous les enregistrements marqués.

Contenu de la base de données

Cette grille vous permet de vous rendre compte du nombre d'enregistrements présents dans les tables de votre base de données.

Il ne s'agit que d'une partie purement informative.


Options "Application"

Options "Application"

Cette partie permet de configurer toute la partie applicative de Movie Collection.

Editer catégories de films

Cette option permet de renommer, ajouter ou supprimer des catégories de films lorsqu'elles ne sont pas utilisées.

L'expression catégorie de films est employés au sens du type de films (Action / Policier...)

Editer emprunteurs de films

cf Emprunteurs de films.


Options "Application : Listes de valeurs"

Options "Application : Listes de valeurs"

Cette partie permet de configurer toutes les listes de valeurs que vous trouverez lors de la saisie d'un nouveau film.

Listes de valeurs

Dans les listes de valeurs modifiables, vous trouverez:

  • Public visé
  • Support
  • Format vidéo
  • Format audio
  • Framerate
  • Source (Provenance du film)
  • Langues
  • Sous titres


Options "Application : Collections"

Options "Application : Collections"

Cette partie permet de configurer vos collections de films. Le concept de collection fait tout simplement référence à un ensemble de films. Certains utiliseront une collection pour les DVD et une autre collection pour les DIVX, d'autres utiliseront une collection pour les Films, une collection pour les Reportages et une collection pour les Mangas.

Le concept de collection est très ouvert et sert à regrouper un ensemble de film.

Activer la référence de film automatique

Cette option permet chaque fois que vous insérez un nouveau film de pré-renseigner automatiquement la référence.

Une référence de film est un identifiant unique du film; ça peut être un numéro, une étiquette...

La référence a été pensée à la base comme le "code barre" du DVD, la VHS...imprimé sur le média.

Masque

Une Collection est composée d'un Code, d'une désignation et d'un compteur.

Pour construire la référence d'un film, un masque de saisie sera utilisé si la case à cochée "Activer la référence de film automatique" est cochée.

Le masque de saisie peut contenir toutes les constantes que vous désirez ainsi que de certains mots-clés qui seront remplacés lors de la construction de la référence.

Le masque de saisie par défaut est : %collection%_%compteur%

%collection% sera remplacé par le code de la collection.

%compteur% sera remplacé par le dernier compteur incrémenté de 1.

La référence d'un nouveau film affecté à une collection (code: DVD, dernier compteur 120) sera DVD_121

Nombre de chiffres de la référence

Le nombre de chiffres de la référence par défaut est 3, ce qui veut dire qu'en utilisant le masque du paragraphe précédent pour le film 1, la référence construite sera DVD_001.

Editer Collections de films

Cette option permet de modifier / insérer / supprimer des collections de films.

A partir du moment où vous aurez créé au moins une collection de film, le bouton d'accès à la liste des films disposera d'un menu contextuel qui vous permettra de lister seulement les films de la collection que vous aurez sélectionné.

Utiliser des collections vous permet aussi de diminuer les temps de réponse lorsque Movie Collection construit la liste des films, fait des recherches... Ce qui paraît normal puisque vous ne travaillez plus sur la totalité de vos films.

Dans la liste des collections, vous remarquerez la présence d'une case à cocher qui permet de cacher certaines collections de films. Cette case à cocher vous permet de masquer certaines collections de films lorsque vous utilisez le serveur web ou tout simplement durant l'utilisation du logiciel, ce qui peut être pratique pour des collections de films adultes...

Affecter les films aux collections

cf Module d'Affectation des films aux collections.


Options "Application : Connexion"

Options "Application : Connexion"

Cette partie permet de configurer la manière dont Movie Collection va se connecter à Internet pour les mises à jour, les scripts d'import.... et toutes les fonctions nécessitant une connexion à Internet.

Utiliser un Proxy pour accéder à Internet

Cette option sert à utiliser un Proxy pour l'accès à Internet.

Serveur

Permet de spécifier l'adresse IP du Proxy.

Port

Permet de spécifier le port du Proxy.

Utilisateur

Permet de spécifier l'utilisateur du Proxy.

Mot de passe

Permet de spécifier le mot de passe du Proxy.


Module d'affectation des films aux collections

Module d'affectation des films aux collections

Cette partie permet d'affecter les films aux collections rapidement. Pour chaque film, il est possible de modifier manuellement la collection affectée. Cependant ce travail devient rapidement fastidieux dès lors que vous possédez plusieurs dizaines de films.

Ce module vous permettra aussi de re-numéroter toutes vos références de films en quelques clics.

Attention, le masque de numérotation automatique des références doit absolument être renseigné correctement !!! (cf Collections)

Pour réorganiser vos films, vous devrez utilisez le "glisser dépasser" (drag & drop) pour réorganiser l'ordre des films et la collection à laquelle ils seront associés. Pour re-numéroter une collection, vous devez sélectionner la collection et appuyer sur le bouton re-numéroter.

Il est aussi possible d'utiliser la multi-selection.

La renumérotation se fait par ordre d'affichage.


Emprunteurs de films

Emprunteurs de films

Cette fiche permet de modifier, ajouter ou supprimer des emprunteurs de films.

Cette fiche et partagée avec les utilisateurs du Serveur Web et permet de configurer les utilisateurs web.


Filtres Graphiques

Filtres Graphiques

Cette fonction est accessible à partir du menu contextuel de la vignette d'un film (sur la fiche de détail du film) ou en double cliquant sur cette même image.

Luminosité

Permet de régler la luminosité de l'image.

Contraste

Permet de régler le contraste de l'image.


Informations

Informations

Le panneau d'information s'affichant à l'ouverture de Movie Collection permet d'avoir un récapitulatif du contenu de la base de données, des options actives, des plug-ins disponibles...

Paramétrage

Cette option permet de voir l'état des paramètres de Movie Collection.

Plug-ins

Cette option permet de visualiser rapidement la liste des plug-ins disponibles.

Base de données

Cette option permet d'avoir un aperçu rapide du contenu de la base de données.

Vous pouvez cliquer sur "Films Prêtés " ou "Films qui auraient du être rendu" pour voir apparaître la liste des films empruntés.

Un clic gauche sur un film prêté vous donne accès aux informations relatives au prêt du film.

Un clic gauche sur le nom de l'emprunteur d'un film vous donne accès à la fiche de l'emprunteur pour retrouver son téléphone par exemple.

Un clic droit sur un film prêté vous donne un raccourci pour marquer le film comme récupéré.


Serveur Web

Serveur Web

Le serveur web vous permet de consulter vos films a distance via Internet.

Port du serveur

Le port par défaut des Serveurs Web (Apache, IIS...) est 80.

Le port par défaut attribué au Serveur Web de Movie collection est le 4700.

Si vous possédez un pare feu (Firewall) sur votre connexion Internet, il est nécessaire d'ouvrir le port choisi.

Démarrer

Cette option permet de démarrer le serveur web.

Arrêter

Cette option permet d'arrêter le serveur web.

Ouvrir site

Cette option permet d'ouvrir le site sur votre machine locale.

Utilisateurs

Cette option permet de gérer les utilisateurs qui vont pouvoir accéder au site Internet.

cf Emprunteurs de films.


Films

Films

Le bouton "films" vous permet d'accéder à la liste des films saisis.

Vous pouvez trier vos films en cliquant sur les entêtes de colonnes.

Recherche

Cette option permet de rechercher un film.

Pour accéder à la recherche avancée.

Cacher les entêtes de colonne

Il est possible de cacher les entêtes de colonne de la liste détaillée des films

Onglets

La liste des films possède 3 présentations différentes.

  • Une Liste détaillée multi-lignes avec une vignette du film.
  • Une Liste simple avec des colonnes personnalisables (clic droit / personnaliser les colonnes).
  • Une Liste avec uniquement les vignettes des films.

Prêter un Film

Cette option permet de prêter un film.

Récupérer un Film

Cette option permet de récupérer un film.


Films "Recherche avancée"

Films "Recherche avancée"

Un clic sur la petite ampoule à gauche de la zone de recherche vous donne accès au panneau de recherche avancée.

Fonctionnement

La zone de saisie de la recherche permet de saisir un ou plusieurs mots.

Par défaut la recherche va se faire dans le titre du film.

Si vous voulez changer ce comportement, il vous suffit d'activer ou désactiver les filtres.

Filtres

Vous pouvez cocher / décocher / griser (Filtre ignoré) l'option Films disponibles.

Vous pouvez cocher / décocher / griser (Filtre ignoré) Films déjà vu.

Dans la zone de saisie de la recherche, vous pouvez saisir des noms d'acteurs par exemple et dans ce cas, pour retrouver tous les films d'un acteur donné, il suffira de cocher la case Rechercher dans Acteurs.

Vous pouvez faire de même pour recherche le Titre original du film.

D'autres critères de recherche ont été rajouté comme la catégorie ou la note du film.

Le moteur de recherche s'enrichira par la suite avec de nouveaux filtres.


Films "Prêter"

Films "Prêter"

Informations relatives au prêt d'un film.

Fonctionnement

Après avoir appuyé sur le bouton "prêter", une fiche apparaît qui vous permet de saisir un emprunteur, une date de prêt, une date de retour et une observation.

Si vous saisissez un emprunteur qui n'existe pas, une fiche de création d'emprunteur apparaît.


Imports

Imports

Le bouton "imports" vous permet d'importer des films depuis d'autre logiciel de gestion de Vidéos.

Liste des logiciels

Ant Movie Catalog.

eXtreme Movie Manager.

BaseDVDivx.

Principe de fonctionnement

Lorsque vous importez des films, une nouvelle collection est automatiquement créée et contiendra tous les films importés.

Vous n'aurez plus qu'à utiliser le module d'affectation des films aux collections pour déplacer les films dans des collections existantes.


Exports

Exports

Le bouton "exports" vous permet d'exporter les films visibles de la liste des films vers un autre format de fichier.

Les exports s'adaptent à l'onglet actif de la liste des films et ne sont exportées que les données visibles à l'écran.

Excel

Vous pouvez exporter vers Microsoft Excel.

Le type d'export proposé est un export binaire.

L'avantage d'un tel export est que vous n'avez pas besoin d'avoir installé Excel sur votre machine pour pouvoir créer un fichier binaire compatible Excel 97.

Il est donc possible d'utiliser la suite de Sun (StarOffice), OpenOffice... en remplacement de la suite de Microsoft (Office).

XML

Vous pouvez exporter vos films au format XML.

Cet export servira plus tard à Movie Collection lorsque j'aurais développé un import XML, pour partager des listes de film avec d'autres utilisateurs.

Ce format d'export est aussi le format qui vous servira a développer vos propres passerelles vers d'autres logiciels si vous désirer vous interfacer avec Movie Collection.

HTML

Vous pouvez exporter vos films au format HTML.

Cet export vous servira à mettre votre liste de films en ligne si vous le désirez ou tout simplement à voir votre liste avec votre navigateur.

Il est à noter que l'export HTML est prévu pour fonctionner avec Internet Explorer 6.

Texte

Vous pouvez exporter vos films au format Texte.


A propos

A propos

  • Historique des versions.
  • Informations sur l'auteur, liens...


Historique des versions

Historique des versions

Version 3.0.1.0

Corrections de fautes d'orthographe dans les options et dans le module d'affectation des films aux collections.

Historique des prêts.

Amélioration de la fenêtre de Filtres graphiques.

Changement du port par défaut du serveur web à 4700.

Possibilité de voir le détail des films à partir du serveur web.

Import à partir du logiciel BaseDVDivX.

Rédaction aide en ligne.

Version 3.0.0.0

Ajout d'un champ "date" qui permet de saisir la date de visionnage du film.

Correction bug sur l'écran de personnalisation des colonnes (les colonnes disparaissent quand on appuie sur escape ou que l'on ferme la fiche avec la croix).

Rajout de la note dans les critères de recherche avancée.

Rajout de la catégorie dans les critères de recherche avancée.

Vous pouvez utiliser la combinaison de touche [CTRL+SHIFT+M] pour changer la casse (Majuscules à la première lettre) d'un champ texte de la fiche d'un film. Seul le champ actif sera modifié.

Intégration d'un serveur web dans Movie Collection pour consulter vos films en ligne.

Version 2.6.3.0

Gestion du format d'image png.

Amélioration des redimensionnement des images (antialiasing).

Possibilité de régler la luminosité et le contraste des vignettes.

Nouvelle fenêtre de filtres graphiques.

Changement de tous les icônes.

Import depuis le logiciel eXtremeMovieManager.

Rajout de champs sur les emprunteurs pour leur donner accès au Serveur Web (Autorisé / Utilisateur / Mot de passe) en vue de la version 3.

Version 2.6.2.3

Rajout du moteur de recherche sur le script DVDFR.

Rajout du moteur de recherche sur le script dvdanime.

Rajout du moteur de recherche sur le script yo-video.

Rajout du moteur de recherche sur le script asia-diffusion.

Rajout d'infos bulle dans la fenêtre d'interrogation du moteur de recherche des scripts indiquant l'adresse pointée.

Correction du script de recherche dvdfly qui fonctionnait mal.

Suppression du script buy-scores car le site a été modifié.

Suppression des messages d'avertissement dans la fenêtre de choix des scripts concernant les scripts n'ayant pas de moteur de recherche (Ils en ont tous un maintenant).

Version 2.6.2.2

Correction bug listes paramétrables (Langues, soustitres...).

Version 2.6.2.1

Correction bug import depuis le logiciel "Ant Movie Catalog".

Version 2.6.2.0

Export Excel de l'onglet vignette de la liste des films.

Rajout du champ Date Ajout.

Rajout du champ Source

Rajout du champ Producteur

Rajout du champ Langues

Rajout du champ Sous-titres.

Possibilité d'importer les films depuis le logiciel "Ant Movie Catalog".

Ecriture d'un moteur de gestion de plug-ins pour gérer les imports à partir d'autres logiciels.

Rajout du moteur de recherche sur le script DVDFLY

Rajout du moteur de recherche sur le script CINEFIL

La référence de film n'est plus unique (cela pouvait poser des problèmes avec l'import depuis Ant Movie Catalog)

Rajout de listes de valeurs sur le champ Source (TV, Echange..)

Version 2.6.1.1

Correction bug, les films non affectés à des collections n'apparaissent pas dans la liste.

Version 2.6.1.0

Possibilité d'afficher/lire les fichiers externes liés à un film.

Personnalisation des listes suivantes: Support, Format vidéo/audio, Public Visé, Framerate

Lors de l'insertion d'un média ou d'une image, la fenêtre de sélection d'un fichier s'ouvre directement lors de l'appuie sur insérer.

Rajout du nombre de listes de choix dans le panneau d'information.

Possibilité de cacher des collections de films pour vos petites collections indiscrètes.

Rajout taille de la base de donnée dans le panneau informations.

Signalisation des films prêtés dans la vue simple des films.

Signalisation des films prêtés dans la vue vignette des films.

Rajout import film X.

Rajout de regroupement dans la liste des scripts d'import.

Version 2.6.0.2

Rajout moteur de recherche sur l'import Moviecovers.

Rajouter "-10 ans" à public visé.

Cacher la liste de choix des collections si la gestion des collections n'est pas activée !

Traduction de l'installeur de MovieCollection.

Version 2.6.0.1

Rajout d'un champ affichable dans la liste des colonnes pouvant contenir tout et n'importe quoi (dans le détail d'un film onglet suppléments).

Amélioration import alapage.com, le nom des acteurs de la recherche apparaissaient en majuscules.

Correction violation d'accès lors de l'appel aux imports alapage & allociné.

Version 2.6.0.0

Pouvoir exécuter un script d'import en double cliquant dessus.

Pouvoir ouvrir le détail du film sur toutes les vues par double clic.

Export HTML de la liste simple des films

Gestion multi-collection.

Module affectation rapide des films aux collections.

Correction bug sauvegarde position fenêtre principale dans la base de registres.

La vue vignette peut être triée par référence en utilisant le clic droit La fiche du détail d'un emprunteur n'est plus modifiable.

Certaines fiches valident explicitement les modifications à la fermeture, maintenant on pose la question.

Dans la liste des emprunteurs de films, un double clic sur l'emprunteur ouvre le détail de l'emprunteur.

Optimisation de la vitesse d'ouverture de l'onglet liste simple dans la liste des films. (La première fois était très lente)

Sauvegarde du dernier onglet sélectionné dans la liste des films.

Version 2.5.0.1

Correction problème script à alapage Correction problème moteur de recherche.

Version 2.5.0.0

Amélioration du moteur de script pour ne plus passer par Internet Explorer pour les imports.

Amélioration du moteur de script.

Les scripts qui ont été adaptés: Allociné, alapage.

Dans le mode vignette, forcer le titre du film sur une seule ligne Mémorisation du masquage des entêtes de colonne.

Mémorisation largeur des images du mode vignettes.

Réécriture import Alapage.com.

Après un import mémorisation du dernier script utilisé et présélection de ce dernier à la prochaine ouverture de la fenêtre des scripts.

Déplacer le bouton "filtre par défaut" du panneau de recherche avancée dans la zone de recherche et le remplacer par une flèche.

Remplacement de l'ampoule qui permettait d'activer la recherche avancée par un bouton plus explicite.

Toutes les options du menu contextuel de la liste des films sont maintenant les mêmes sur chaque vue (détail, simple, vignettes), il est donc possible de prêter un film sur la vue vignette...

Il est maintenant possible de récupérer un film directement à partir du panneau d'information.

Rajout recherche par acteurs.

Correction de bug pouvant créer une violation d'accès à la fermeture du détail d'un film.

Correction du moteur de mise à jour de la base de données au niveau de certaines contraintes de vérification qui pouvaient être créées plusieurs fois et créer des ralentissements.

Rajout d'un champ public visé (-18, -16, -12, tous public, etc...).

Version 2.4.0.1

Correction bug couleur zone de saisie (notamment pour les personne qui utilisent le thème XP gris).

Version 2.4.0.0

Le bouton pour appliquer les filtres est déporté dans le clic droit sur image pour laisser plus de place à l'affichage.

Ajout d'une case à cocher pour afficher / cacher les entêtes de colonnes.

Modification Liste de Formats Video/Audio.

Rajout onglet Vignettes dans liste des films.

Optimisation et réécriture du module de connexion à Internet (script/verif version).

Les couleurs des films disponibles et des films prêtés sont maintenant paramétrables.

Pouvoir modifier les emprunteurs après les avoir créés (comme pour les catégories de films).

Interface "skinable" (couleur d'ambiance).

Accès rapide aux données saisies sur le prêt du film (possibilité de changer la date de retour prévue et de rajouter un commentaire) à partir du panneau d'information.

Accès rapide aux données de l'emprunteur (email/ téléphone...) à partir du panneau d'information.

Problème de fond noir sur certains thèmes de windows.

Optimisation de l'espace dans la liste des films, la recherche avancée n'est accessible maintenant qu'en cliquant sur l'ampoule à gauche de la zone de saisie des critères de recherche.

La recherche ne cherche plus par défaut dans le titre original.

Possibilité de supprimer les entêtes de colonnes dans la liste des films détaillée (gain de place).

Export de la liste films en fichier texte.

Rajout d'un bouton dans le panneau de recherche pour effacer tous les filtres et revenir au mode de recherche par défaut.

Possibilité de lier des images à un film en tant que fichier externe (elles ne sont pour l'instant pas exploité).

Possibilité de lier des fichiers média (avi...) à un film en tant que fichier externe (pas encore exploité).

Version 2.3.0.0

Relook complet de l'appli avec nouveaux icônes, support des thèmes Windows XP.

Reconditionnement du récapitulatif de la base de données qui est maintenant accessible dans les options du logiciel.

Maintenant une nuance est faite entre le contenu de la base de données (nombre d'enregistrements dans chaque table) et le nouveau panneau (informations) qui contient tout plein d'information récapitulative.

Suppression du libellé sur les fiches film "paramètres recommandés pour l'image...."

L'icône "outils" renommé en "options".

L'option "vérifier la version au démarrage" est renommé car pas clair pour les débutants.

Rajout d'une Boite à Astuces.

Agrandissement de la zone résumé et rétrécissement de la zone acteurs.

Recherche avancée mise en place

Suppression de la question systématique pour l'ouverture des sites avant un import. A la place de cela, rajout d'un bouton pour ouvrir le site sur la page de sélection du script.

Version 2.2.2.3

Correction problème de mise à jour du moteur de base de données pour les nouveaux utilisateurs !

Version 2.2.2.2

Optimisation des vignettes pour avoir moins de pixellisation (bouton appliquer filtres sur le détail d'un film).

Correction fautes d'orthographe.

Correction problème de prêts de films.

Rajout d'une colonne personnalisable (Film disponible).

Version 2.2.2.1

Correction problème au niveau des catégories.

Version 2.2.2

Export au format XML.

Correction: après avoir importé une fiche (par exemple à partir de Allociné), un clic droit sur l'image et 'effacer' provoque une erreur...

Correction: problème de connexion lors de la vérification de version (pour ceux qui sont derrière un Proxy).

Correction: Le compteur de référence est incrémenté lorsqu'on modifie un film

Evo: Les images des imports ne sont maintenant plus reconnues par rapport à leur extension mais par rapport à leur signature numérique.

Evo: Rajout dans les imports des jaquettes au format bmp.

Evo: Personnalisation des colonnes de l'affichage simple.

Version 2.2.1

Dupliquer une fiche à la demande de Yak.

Re-écriture import dvdfly.

Incrémentation automatique des références de films.

Import www.asia-diffusion.com.

Correction problème import au niveau du titre sur le site dvdfr www.dvdfr.com>

Ajout du format vidéo OGM: Fichier Vidéo Ogg Media.

Ajout du format vidéo MKV: Fichier Vidéo Matroska.

Recherche par genre de films.

Correction bug import jaquette sur le site allocine.

Version 2.2

Importante modifications au niveau du moteur de mise à jour de la base de donnée, ceci pourra se constater chez certaines personnes qui n'arrivaient pas à saisir d'accents dans certains champs.

Import de dvd audio à partir du site www.buy-scores.com .

Correction import allocine (report ancien moteur + améliorations).

Correction problème d'export de la base de données qui ne tient pas compte du nom de fichier de sortie choisi.

Version 2.1

Nettoyage du répertoire où sont stockées les vignettes après un export Excel multi lignes.

Ecriture d'un nouveau moteur d'import.

Import de mangas à partir du site www.dvdanime.net .

Support des Proxy pour les connexions à Internet.

Possibilité de savoir si les films ont été déjà vus.

Rajout de la colonne note dans l'affichage simple pour pouvoir trier les films par note.

Version 2.0

Gestion de prêts de films.

Le site [DVDFLY] vient de changer, l'import est désactivé.

Amélioration du moteur de mise à jour de la base de données.

Version 1.5.4.1

Amélioration des imports.

Rajout d'un champ pour avoir le site officiel du film.

Correction de bugs reportés.

Version 1.5.4

Rajout import cinemovies.fr.

Rajout de champs sur le détail d'un film, format vidéo / audio / résolution ...

Correction problème d'accent chez certaines personnes dans les catégories notamment.

Vérification unicité des références de film. (Si vous avez des doublons, la contrainte ne sera pas activée).

Version 1.5.3.1

Correction d'un bug sur l'export Excel (mémoire insuffisante...).

Optimisation des images importées manuellement dans la base de données ( par un import classique).

Version 1.5.3

Possibilité de supprimer / modifier des catégories de films.

Correction bug grille lorsqu'on double clique sur entête de colonne pour trier la fenêtre de détail s'ouvre.

Rajout d'un index unique sur les références de films.

Possibilité de choisir si on veut les vignettes au nom lors de l'export Excel multi-lignes.

Division de la zone d'édition d'un film en deux onglet, et rajout d'informations sur le film : « Titre original », « Pays ».

Réorganisation de la zone d'outils.

Création de 2 onglets dans la liste de film, un pour la vue simple et un pour la vue détaillée: L'export Excel tiendra compte de la vue active.

Rajout de la dernière version du moteur de base de données.

Version 1.5.2

Correction bug import allociné (Problème d'import sur les films n'ayant pas de jaquette).

Version 1.5.1

Correction bug import allociné.

Amélioration des téléchargements Internet avec fenêtre d'avancement.

Version 1.5

Rajout de l'import à partir du site www.allocine.fr .

Amélioration de l'import dvdfly (import de la catégorie).

Ouverture du site lorsque une nouvelle version est disponible.

Rajout de la catégorie dans la liste de films (possibilité de trier).

Lors des imports possibilité de ne pas ouvrir systématiquement le site de téléchargement (plus pratique lorsque de nombreux films sont à importer sur le même site).

Ouverture du site lorsque la version n'est pas à jour.

Version 1.4

Possibilité de choisir le répertoire de sauvegarde de la base de données.

Rajout d'une fonctionnalité d'optimisation de la base.

Rajout de la restauration de la base.

Rajout d'un moteur de mise à jour de la base de données (même à partir de vieilles sauvegardes qui seraient restaurées).

Rajout de notes sur les films.

Rajout d'un commentaire sur les films.

Rajout d'une notion de catégorie sur les films (Action, Aventure.)

Rajout des catégories de film dans le compte rendu de la base.

Rajout d'un moteur de recherche.

Version 1.3

Correction bug check version.

Rajout des vignettes dans l'export Excel (Tel qu'a l'écran).

Version 1.2

Modification icône export Excel.

Rajout d'un export Excel linéaire et multi ligne.

Importation de la jaquette au niveau du module import DvdFly.

Rajout d'une fonctionnalité de vérification de version pour être informé des mises à jour.

Modification de l'icone pour voir la liste des films.

Version 1.1

Import des données à partir du site http://www.dvdfly.com/. [DVDFLY]

Interdiction de lancer plusieurs instances du programme.

Rajout d'info bulles dans l'application (HINT).

Suppression du Freeze de l'application lors de l'import [DVDFLY].

Rajout d'une protection contre les page qui pourrait être invalide ou différentes des autres [DVDFLY]


Informations sur l'auteur, liens...

Informations sur l'auteur, liens...

Ce programme a été créé par Babidyxp.

Il est prévu pour tourner sous Windows 2000, XP, et a été testé sur ces différents systèmes.

Site officiel | http://babidyxp.free.fr/
Forum | http://babidyxp.free.fr/phpBB2/
Email | babidxp@free.fr

Ce programme est un freeware et vous pouvez l'utiliser gratuitement.